Resolved! - INC152380 - Duplicate January 16 CAD and USD FX Drafts settlement postings
Incident Report for Central 1
Resolved
Central1 would like to advise you that on January 16, 2023, the CAD and USD FX Drafts settlement postings were processed twice in error.

We have reversed the duplicate entries that were posted to your Central1 account in error with the effective date Jan 16, 2023.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jan 19, 2023 - 10:29 PST