Alert! - RESOLVED - INC148697 - Home Trust Visa Delayed Payments for September 10
Incident Report for Central 1
Resolved
Home Trust Visa has resolved their issue. All payments will be applied and backdated to original date of September 10.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 28, 2022 - 10:18 PDT
Update
Central 1 is actively following up with Home Trust Visa and we have been advised that they are still investigating the issue on their side.

We will provide another update on Thursday, September 29, or sooner if we receive word from the biller that the issue has been resolved.
Posted Sep 27, 2022 - 09:01 PDT
Monitoring
Home Trust Visa has advised Central 1 there is a delay in processing payments made on September 10. They are actively investigating and all payments will be backdated to original payment date. Only payments made on September 10 were affected.

Central 1 will advise when Home Trust Visa has been able to resolve their issue.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 23, 2022 - 13:12 PDT
This incident affected: Payment Services.