INC178121- 2-Step Verification SMS Delays
Incident Report for Central 1
Resolved
Central 1 has received notification that the SMS delays have been resolved. Your customers should no longer experience delays receiving SMS messages.
Posted Apr 05, 2024 - 18:10 PDT
Investigating
Central 1 has been informed by our 2 step verification service provider that they are currently experiencing technical issues, and this may cause a delay in the delivery of SMS text messages.

TeleSign is investigating this incident and we will provide updates as we receive them.

Central 1 - DigitalBanking_Support@Central1.com - 1.888.889.7878, option 2
Posted Apr 05, 2024 - 09:14 PDT
This incident affected: Digital Banking Services and Incident Alerting.