INC214606 - USD Branch Capture settlement and reporting is incomplete for ON and BC organizations

Incident Report for Central 1

Resolved

The settlement and reporting for the USD cheques scanned on December 29th is now complete.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Dec 31, 2025 - 07:27 PST

Monitoring

Due to a technical issue, the USD cheques scanned yesterday (December 29, 2025) were not included in your CAS USD current account posting or on your USDJ\AIOU “Account Activity and Balances” report.

The settlement and reporting will be processed this evening and will appear in your USD account and report tomorrow morning (December 31, 2025).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Dec 30, 2025 - 11:57 PST
This incident affected: Payment Services.