INC183381 - RESOLVED - Enterprise Fraud Management (EFM) not accessible
Incident Report for Central 1
Resolved
All users should now be able to access EFM. Thank you for your patience while we worked on resolving this incident and we apologize for any inconvenience caused.

If you continue to experience issues with accessing EFM, please reach out to Support.
Posted Jul 22, 2024 - 10:20 PDT
Investigating
Central 1 is aware that some users are not able to access EFM. Our technical team is actively working to resolve this issue as quickly as possible. Please note that our back-end system is still fully operational, and EFM is still monitoring your transactions.

If you require support on Wires status, please contact our Wires Desk. If you are looking for support on eTransfers, please contact Digital banking support.

We understand the inconvenience this may cause and assure you that restoring full functionality is our top priority.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jul 22, 2024 - 09:12 PDT
This incident affected: Payment Services and Incident Alerting.