INC212586 - Client Centre Access Issue

Incident Report for Central 1

Resolved

Organizations can now access the Client Centre and applications. Please use a clean browser to open the Client Centre by closing all your old browsers.

If you continue to experience issues accessing the Client Centre, contact Central 1 Client Support.

entral 1 - Support@central1.com - DigitalBanking_Support@central1.com - 1.888.889.7878
Posted Nov 20, 2025 - 07:28 PST

Investigating

The Central 1 team is actively investigating an accessibility issue for some users to the Client Centre (Clients.Central1.Com). We are conducting a thorough analysis of the systems involved and working toward resolving the issue.

In the meantime, please use the following URL to access applications https://ststaticwebsorrypage002.z9.web.core.windows.net/.

We will provide our next update at 6:30 a.m. PT (9:30 a.m. ET).

Central 1 - Support@central1.com - DigitalBanking_Support@central1.com - 1.888.889.7878
Posted Nov 20, 2025 - 05:56 PST
This incident affected: Central 1 Services, Payment Services, Treasury Services, and Digital Banking Services.