INC208255 - FX Drafts Access Issue on Chrome

Incident Report for Central 1

Resolved

Convera has reported that the FX Drafts access issue via the Chrome browser has been resolved.

If you continue to have FX Drafts access problems using Chrome, please contact Central 1 Support.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 04, 2025 - 07:37 PDT

Investigating

Some users of FX Drafts have reported receiving error messages when attempting to access FX Drafts via Chrome. Central 1 has reached out to Convera to report the matter and to request support. As soon as we have an update from them, we will share the information.

In the meantime, we are aware of users successfully accessing the application when using Firefox or Edge.

We will provide an update by tomorrow, September 4, at 7:30 am PT (10:30 am ET).


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 03, 2025 - 13:56 PDT
This incident affected: Payment Services.