Alert! - RESOLVED - INC144017 - Secure Site Unavailable
Incident Report for Central 1
Resolved
This incident has been resolved. Access to the Secure Site has been restored.
Posted May 21, 2022 - 05:38 PDT
Investigating
The Secure Site (www.secure.central1.com) is currently unavailable. Technical support is investigating.

We will provide an update by 6:30 a.m. PT (9:30 a.m. ET).


Central 1 - Support@central1.com - DigitalBanking_Support@central1.com - 1.888.889.7878
Posted May 21, 2022 - 05:09 PDT
This incident affected: Critical/High Priority Incident Alert and Secure Site & User Management.