INC212611 - RESOLVED - Incorrect amounts posted for November 19 Everlink POS and SCD settlements

Incident Report for Central 1

Resolved

The reversal of the incorrect settlement amounts and the posting of the correct amounts was completed yesterday.

This incident is now resolved.
Posted Nov 21, 2025 - 06:29 PST

Identified

***This notification is for credit unions that use Everlink as their switch provider***

Please note that incorrect amounts have been posted to your Central 1 account(s) for the November 19 Everlink POS and SCD settlements.

The incorrect settlements will be reversed shortly, and the correct amounts posted. We will provide an update once this has been completed.


Central 1 - Support@central1.com - 1.888.889.7878 option 1
Posted Nov 20, 2025 - 11:06 PST
This incident affected: Payment Services.