INC208304 - RESOLVED - User Management (UM) Performance

Incident Report for Central 1

Resolved

The performance issues for UM have been resolved. The Manage Requests option is now accessible.

Thank you for your patience and we apologize for any inconvenience this may have caused.
Posted Sep 04, 2025 - 10:15 PDT

Investigating

Central 1 is aware that some users are experiencing slowness when using UM. In addition, the Manage Requests option is not loading or returning an error message. Our technical Support team is currently investigating this incident.

We will provide an update by 10 am PT (1 pm ET).


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 04, 2025 - 09:03 PDT
This incident affected: Payment Services.