INC208948 - PaymentStream Direct (PSD) Administration Tab Accessibility

Incident Report for Central 1

Identified

Our technical team has identified high latency affecting the Administration tab in PaymentStream Direct. To mitigate, we are preparing to shift service to our disaster recovery (DR) environment. This action is expected to improve stability.

We are targeting 3:00 p.m. PT (6:00 p.m. ET) for this change, after which validation testing will be performed to confirm restored access. In the meantime, the Administration tab remains available, although performance is degraded with timeouts and errors possible.

We will provide another update once the failover has been completed and validated, or sooner if there are material changes to report.
Posted Sep 16, 2025 - 13:35 PDT

Investigating

Central 1 is aware that users are experiencing extreme slowness or error messages when attempting to access the Administration tab in PaymentStream Direct. We have initiated an immediate investigation. Our technical team is gathering data to determine the underlying cause.

The reliability of PaymentStream Direct is important for you and your customers. Therefore, we’re committed to keeping you informed about what is happening in a timely manner. We’ll share an update with you by 1:30 p.m. PT (4:30 p.m. ET), or as soon as we have more information to report on. Thank you for your understanding as we work to resolve the issue.

Central 1 - support@central1.com - 1.888.889.7878, press 1
Posted Sep 16, 2025 - 11:54 PDT
This incident affects: Central 1 Services and Payment Services.