INC224124 - Cash ordering domination drop-down is blank

Incident Report for Central 1

Resolved

RBC has confirmed that this incident is now resolved.

To get the denominations to appear in the application's drop-down, you need to close all current browser sessions and reopen a fresh session.

Please contact us if you have any further issues with the Cash Ordering application.

Central 1 - Support@central1.com - 1.888.889.7878, press
Posted Jun 29, 2026 - 07:27 PDT

Investigating

Central 1 is aware that the cash ordering domination drop-down is blank in the application when placing an order.

If your order is urgent, please use the ServiceNow cash ordering form.

Our supplier is investigating, and we will have an update by 10 a.m. PT\1 p.m. ET.

Central 1 - Support@central1.com - 1.888.889.7878, press
Posted Jun 29, 2026 - 07:18 PDT
This incident affected: Payment Services.