Resolved! - INC145390 - Treasury Connect is Unavailable
Incident Report for Central 1
Resolved
Treasury Connect is now operational.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jun 22, 2022 - 06:47 PDT
Investigating
Treasury Connect is currently unavailable.

Central 1’s technical team is investigating.

An update will be sent out by 8 a.m. PT (11 a.m. ET), or sooner if service is restored before then.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jun 22, 2022 - 05:48 PDT
This incident affected: Treasury Connect.