INC194054 - Servus Mastercard Payments Delayed - January 15 to 20, 2025
Incident Report for Central 1
Resolved
Servus Mastercard has advised any payments made between January 15 to January 20 were delayed due to their system issues. All delayed payments have now been applied and backdated to the original date of payment.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jan 24, 2025 - 08:48 PST
Monitoring
Central 1 has been advised by Servus Mastercard that, due to technical issues, all payments made on January 16 have not yet been applied. They are actively investigating the matter.

We will provide an update once Servus Mastercard has more information and/or has resolved their issues.


Central 1 – Support@central1.com – 1.888.889.7878, press 1
Posted Jan 23, 2025 - 16:15 PST
This incident affected: Payment Services.