Resolved - INC210741 - FX Drafts - AWS Outage – Service Disruption Update

Incident Report for Central 1

Resolved

Convera has informed Central 1 that all services for FX Drafts have been restored.

If you continue to experience access issues to the FX Drafts application, please contact Central 1 Support.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 21, 2025 - 08:23 PDT

Investigating

Convera has notified Central 1 they experienced a significant outage that impacted access to FX Drafts (GPFI platform) this morning.

While Convera has reported that most services have been restored, they are still experiencing intermittent disruptions.

For any urgent matters, please contact Convera directly:

• CAMFI Support: CAMFI@convera.com
• Customer Care: customercare@contact.convera.com or call 1-800-897-6333 (Option 3)

Central 1 will provide an update as soon as we receive one from Convera.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 20, 2025 - 10:56 PDT
This incident affected: Treasury Services.