Resolved - INC202531 - Missing May 31 Everlink POS and SCD Settlement

Incident Report for Central 1

Resolved

We have posted the SCD and POS for the May 31, 2025, Everlink settlement, with the effective of June 2, 2025.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jun 06, 2025 - 05:59 PDT

Identified

This notification is for Ontario and British Columbia credit unions that use Everlink as their ATM/POS service provider.

Everlink’s settlement for May 31st was not processed.

We will provide our next update by Friday, June 6th, 9 a.m. PT / 12 p.m. ET or sooner if the incident has been resolved.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jun 05, 2025 - 12:14 PDT
This incident affected: Payment Services.