INC207675 - LBC Duplicate AFT Items sent August 20th

Incident Report for Central 1

Resolved

Payments Canada has been advised that Laurentian Bank has sent Error Corrections for the duplicate AFT transactions sent in error on August 20th.

Central 1 - PaymentStream_Support@central1.com - 1.888.889.7878, option 1
Posted Aug 22, 2025 - 07:56 PDT

Update

The latest update from Payments Canada is that Laurentian Bank is in the process of sending out Error Corrections for the duplicate transactions.

The timeframe for the Error Corrections is unknown.

We will continue to monitor this situation and provide an update when further information is received from Payments Canada.

Central 1 - PaymentStream_Support@central1.com - 1.888.889.7878, option 1
Posted Aug 22, 2025 - 04:20 PDT

Identified

Payments Canada has notified Financial Institutions that Laurentian Bank sent duplicate transactions in their file in the afternoon exchange on August 20, 2025.

We will continue to monitor this situation and provide updates as we receive information from Payments Canada.

Central 1 - PaymentStream_Support@central1.com - 1.888.889.7878, option 1
Posted Aug 21, 2025 - 13:02 PDT
This incident affected: Payment Services.