INC210815 - TD - Customer Account Posting Issues

Incident Report for Central 1

Resolved

Payments Canada has advised Central 1 that TD has resolved their internal issue.

The posting of their customer credits was completed as of 9:45 a.m. PT (12:45 p.m. ET).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 21, 2025 - 10:59 PDT

Monitoring

Payments Canada has advised Central 1 that TD is experiencing an internal issue that is impacting its ability to post transactions to customer accounts.

The estimated time of recovery is unknown.

Follow-up notices will be distributed as new information is available to Central 1 or once the situation is resolved.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 21, 2025 - 08:29 PDT
This incident affected: Payment Services.