Resolved - Alert! - INC155287 - Cash Services not available to order cash
Incident Report for Central 1
Resolved
The drop down to select denominations when placing a cash order is now available in the cash services application.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Mar 22, 2023 - 06:16 PDT
Update
RBC continues to work to restore functionality to the cash services application.

If you have an urgent cash order, please contact Central 1 Client Support to receive a cash order form to email to RBC.

Central 1 will provide an update to this incident at 9 a.m. PT (12 p.m. ET).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Mar 21, 2023 - 12:39 PDT
Update
RBC continues to work to restore the cash services application.

If you have an urgent cash order, please, contact the RBC Cash Services Support Centre toll-free number 1-888-880-3033 to have them enter the cash order on your behalf or contact Central 1 Client Support to provide you with a form that can be emailed to RBC.

Central 1 will provide an update to this incident at 1 p.m. PT (4 p.m. ET).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Mar 21, 2023 - 10:06 PDT
Update
RBC’s technical Team is working on restoring functionality to the cash order drop down to select denominations so that cash orders can be submitted for fulfilment.

If you have an urgent cash order you can contact the RBC Cash Services Support Centre toll-free number 1-888-880-3033 to have them enter the cash order on your behalf or contact Central 1 Client Support to provide you with a form that can be emailed to RBC.

Central 1 will provide an update to this incident at 10 a.m. PT (1 p.m. ET).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Mar 21, 2023 - 06:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2023 - 13:34 PDT
Identified
Credit unions have reported that when trying to place a cash order the drop down to select denominations is not working and the order cannot be submitted.

If your credit union encounters this issue, to order cash, contact the RBC Cash Services Support Centre toll-free number 1-888-880-3033 to have them enter the cash order on your behalf.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Mar 20, 2023 - 13:34 PDT