Resolved - INC225674 – Foreign Exchange (FX Trader) is currently down

Incident Report for Central 1

Resolved

The Foreign Exchange (FX Trader) application is now available.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jul 31, 2026 - 10:44 PDT

Investigating

The Foreign Exchange (FX Trader) via the Treasury Connect application is currently unavailable.

Our technical team is investigating.

Should you require an urgent trade, please contact our Treasury Department at treasury@central1.com or by calling 1-800-661-6813 x 8487.

An update will be sent out by 10:30 a.m. PT (1:30 p.m. ET).

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Jul 31, 2026 - 09:11 PDT
This incident affected: Treasury Services.