INC220235 - RESOLVED - PaymentStream Direct not accessible

Incident Report for Central 1

Resolved

Service has been restarted and PaymentStream Direct is now fully accessible.

Thank you for your patience during this service outage.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Apr 19, 2026 - 12:47 PDT

Investigating

Central 1 is aware that PaymentStream Direct is not accessible and have initiated an immediate investigation. User will receive an error message that the server is unavailable after entering the 2-step token code.

Keeping you informed during this incident is important to us. We’ll share another update with you by today at 2 p.m. PT (5 p.m. ET), or as soon as we have significant developments to report on. Thank you for your patience.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Apr 19, 2026 - 12:04 PDT
This incident affected: Payment Services and Incident Alerting.