INC223539 - Missing Unqualified Items - June 16, 2026

Incident Report for Central 1

Update

We are continuing to investigate this issue.

An update will be provided by 12 pm PT (3 pm ET).


Central 1 – support@central1.com – 1.888.889.7878 (press 1)
Posted Jun 17, 2026 - 11:13 PDT

Investigating

Some clients may be missing their Unqualified clearing items for June 16. We are actively investigating the matter.

We will provide the next update by 11 am PT (2 pm ET) with the latest information.


Central 1 – support@central1.com – 1.888.889.7878 (press 1)
Posted Jun 17, 2026 - 09:20 PDT
This incident affects: Payment Services.