Alert! - RESOLVED - INC148636 - Collabria Visa and Mastercard Delayed Payments for September 16
Incident Report for Central 1
Resolved
Collabria has resolved their incident and posted all Visa and Mastercard payments made on September 16 with no late penalties applied to the accounts.
Posted Sep 23, 2022 - 08:56 PDT
Monitoring
Collabria has advised Central 1 that they experienced system issues which has led to a delay in processing of Collabria Visa and Mastercard payments made on September 16.

Collabria is actively investigating and all payments will be backdated to original payment date. Only payments made on September 16 were affected.

Central 1 will advise when Collabria Visa and Mastercard has been able to resolve their issue.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Sep 22, 2022 - 11:52 PDT
This incident affected: Bill Payments.