Resolved - INC219102 - Client Centre Access Issues

Incident Report for Central 1

Resolved

The Client Centre (Clients.Central1.Com) access issues have been resolved.

Central 1 - Support@central1.comDigitalBanking_Support@central1.com - 1.888.889.7878
Posted Mar 30, 2026 - 07:36 PDT

Investigating

Users are experiencing an accessibility issue with the Client Centre (Clients.Central1.Com) and the services and applications behind the Client Centre. We are conducting a thorough analysis of the systems involved and working toward resolving the issue.

Central 1’s technical team is investigating and will provide another update by 8:00 a.m. PT (11:00 a.m. ET).

Central 1 - Support@central1.comDigitalBanking_Support@central1.com - 1.888.889.7878
Posted Mar 30, 2026 - 07:11 PDT
This incident affected: Central 1 Services, Payment Services, Treasury Services, Digital Banking Services, and Incident Alerting.