INC222036 – Client Centre unavailable

Incident Report for Central 1

Resolved

Client Centre service has been restored, and access is now fully available at https://clients.central1.com/.

As part of the resolution, Central 1 has successfully transitioned Client Centre off the previous 3rd party hosting environment and into our Azure infrastructure. This change is intended to improve overall service stability and resiliency going forward.

We will continue to monitor performance closely to ensure a stable experience for our clients. If you experience any issues accessing Client Centre, please refresh your browser or clear your cache before attempting again.

We appreciate your patience and understanding throughout this incident.

Central 1 Support - support@central1.com - 1 888 889 7878 (press 1)
Posted May 22, 2026 - 14:53 PDT

Identified

Central 1 is currently experiencing a recurrence of the Client Centre access issue. Users may encounter the “Sorry Page” when attempting to access the site.

Our teams are actively engaged and escalating with our vendor to address this issue. In parallel, we are working on alternative solutions to mitigate the impact and resolve the underlying environment issue as quickly as possible.

The “Sorry Page” remains available and provides access to key applications via direct links. We will continue to provide updates as more information becomes available and appreciate your patience.

Central 1 Support - support@central1.com - 1 888 889 7878, press 1
Posted May 21, 2026 - 18:21 PDT
This incident affected: Payment Services, Treasury Services, and Digital Banking Services.