Resolved - INC215673 – Microsoft Outlook / Email Distribution Degradation

Incident Report for Central 1

Resolved

Microsoft has resolved the technical issues affecting Outlook and Microsoft 365.

Central 1 Support - Support@central1.com - 1-888-889-7878, press 1
Posted Jan 23, 2026 - 04:35 PST

Identified

Central 1 is aware of an ongoing service disruption impacting Microsoft Outlook and Microsoft 365, which has been reported as sporadic and continuing to degrade across multiple regions.

At this time, Central 1 is not aware of any confirmed impacts to our services. However, given the nature of the reported issue, there is a possibility that email delivery may be delayed or intermittently affected.

If you have sent Central 1 an important email and have not received a response within your usual turnaround time, we recommend calling Support to ensure your message was received successfully.

Central 1 Support - Support@central1.com - 1-888-889-7878, press 1
Posted Jan 22, 2026 - 14:59 PST
This incident affected: Central 1 Services, Payment Services, Treasury Services, and Digital Banking Services.