Update - INC224124 - Cash ordering domination drop-down is blank

Incident Report for Central 1

Monitoring

RBC has implemented a fix for the cash ordering denomination drop-down issue.

Some users have reported success in selecting denominations after closing all browser sessions and opening a new browser before placing their order.

However, other users continue to experience issues with the application.

If your order is urgent, please submit it using the ServiceNow Cash Ordering Form.

We will provide our next update by 7:00 a.m. PT / 10:00 a.m. ET tomorrow.

Central 1 - Support@central1.com - 1.888.889.7878, press
Posted Jun 29, 2026 - 12:53 PDT

Update

Organizations continue to experience issues with cash ordering. The drop-down menu remains blank, even when using a fresh browser during order placement.

If your order is urgent, please submit it using the ServiceNow cash ordering form.

Our supplier is currently investigating the issue, and we will provide an update by 1:00 p.m. PT \4:00 p.m. ET.

Central 1 - Support@central1.com - 1.888.889.7878, press
Posted Jun 29, 2026 - 10:07 PDT

Identified

Credit unions have confirmed that the cash ordering domination drop-down remains blank even after using a fresh browser when placing an order.

If your order is urgent, please use the ServiceNow cash ordering form.

Our supplier is investigating, and we will have an update by 10 a.m. PT\1 p.m. ET.

Central 1 - Support@central1.com - 1.888.889.7878, press
Posted Jun 29, 2026 - 08:06 PDT
This incident affects: Payment Services.