INC178151 - RESOLVED - Add Biller feature temporarily unavailable
Incident Report for Central 1
Postmortem

Postmortem:  INC178151 – ARU BP Clients unable to add new vendors through BH or Online Banking - Priority High 

 On Friday, April 5, Central 1’s bill payment clients who use ARU messaging experienced an incident between 11:40 a.m. and 2:16 pm PT (2:40 pm and 5:16 pm ET) where new billers could not be added to customer’s profiles.

 The incident was resolved by restarting Central 1’s vendor validation module.  During this time payments to existing biller setups were not impacted.

 Point of failure: The incident was caused by a bug in the error handling of the validation routine for one specific biller.  A credit union member submitted a series of invalid characters for the biller resulting in the validation library crashing because the current validation rule could not handle the error submitted to the system.  Central 1 confirmed that this specific biller was originally set up on May 26, 2023, and this bug was present, however, it was undetected because the required specific conditions were not met before. To mitigate a re-occurrence the development team has addressed the bug and redeployed the biller validation to production. 

 Action:

PRB011244 – Root cause analysis – COMPLETED

  • RITM361332 - Implement eCommSwitch biller account validation library failure alert in Splunk – Complete
  • CHG145632 - Create Verification Routines for New Billers & Changes / Deploy Routines – Complete

At Central 1 we take the quality of our service delivery very seriously. We understand that when our services are not working as expected, it can have a significant impact on our customers and their businesses. We believe that the best way to address any issues that arise is to be transparent about them and work diligently to improve our processes and systems.

 If you have any questions about this postmortem, please reach out to Support@central1.com.  

 Elizabeth Ackroyd, Manager Client Support Services (Payments) | e: eackroyd@central1.com | c: 905-301-1337

Posted Apr 19, 2024 - 08:41 PDT

Resolved
Central 1 ARU bill payment clients experienced an incident between 11:40 a.m. PT and 2:16 pm PT (2:40 pm ET and 5:16 pm ET) where new billers could not be added to customer profiles. The incident was resolved by restarting our vendor validation module. During this time payments to existing biller setups were not affected.

We apologize for the inconvenience this service disruption caused for you and your customers and we will provide a postmortem within the next two weeks.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Apr 05, 2024 - 15:16 PDT
This incident affected: Payment Services and Digital Banking Services.