INC210514 - RESOLVED - Access Issues for PaymentStream Direct

Incident Report for Central 1

Resolved

PaymentStream Direct has remained stable and there have been no further reports of access issues. The incident will now be marked as resolved.

If you do encounter any issues, please reach out to Support.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 17, 2025 - 13:56 PDT

Monitoring

At this time there are no reports of access issues with PaymentStream Direct. We will continue to monitor the application throughout today to ensure it is stable.

We will provide another update by 3 p.m. PT (6 p.m. ET), or sooner if there is any further information to provide.
Posted Oct 17, 2025 - 09:20 PDT

Update

Central 1 continues to investigate the issue where some users are encountering errors when trying to access or use functions within PaymentStream Direct.

Thank you for your understanding and support during this incident. We’ll share our next update with you tomorrow October 17, 2025 by 9:30 a.m. PT (12:30 p.m. ET), or as soon as we have more information to report on.

Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 16, 2025 - 16:16 PDT

Update

Central 1 continues to investigate the issue where some users are encountering errors when trying to access or use functions within PaymentStream Direct.

Thank you for your understanding and support during this incident. We’ll share our next update with you by 4:00 p.m. PT (7:00 p.m. ET), or as soon as we have more information to report on.
Posted Oct 16, 2025 - 14:44 PDT

Investigating

Central 1 is aware some users are encountering errors when trying to access or use functions within PaymentStream Direct. We have initiated an immediate investigation. Our technical support teams are gathering data to determine the underlying cause.”

The reliability of PaymentStream Direct is important for you and your customers. Therefore, we’re committed to keeping you informed about what is happening in a timely manner. We’ll share our next update with you by 2:30 P.m. PT (5:30 p.m. ET), or as soon as we have more information to report on. Thank you for your understanding as we work to resolve the issue.


Central 1 - Support@central1.com - 1.888.889.7878, press 1
Posted Oct 16, 2025 - 13:30 PDT
This incident affected: Payment Services.